This project is read-only.

Can't install

Jun 18, 2010 at 9:28 PM

First I tried to install the "Schedulr.zip (Binaries)" and got a .Net error that said "Unable to find a version of the runtime to run this application."

Then I tried to install the "Schedulr.Setup.zip (Installer)" and it kept saying I needed .Net 2. I installed .Net 4, restarted my computer, and it still said I needed to install .Net2

I'm using Windows XP

Jun 19, 2010 at 8:37 AM
Edited Jun 19, 2010 at 8:38 AM

An application that was built for .NET 2.0 will not automatically run on .NET 4, so there are two options:

- Either you install .NET 2.0 (or better yet: 3.5 SP1) and it will work fine.

- Or you can add the following lines to the Schedulr.exe.config file to make it run under .NET 4 (but note that I have not tested this so I cannot guarantee that it will work correctly). You have to add the red lines right after the <configuration> tag (so before the <configSections> tag):

  <configuration> 
    <startup>
      <supportedRuntime version="v4.0" /> 
    </startup>
    <configSections>
    ...